Linux下PHP升级的方法

Linux系统下安装WordPress提示PHP版本太低,那么如何升级PHP版本?LAMPLNMP分享Linux系统下PHP版本升级的方法:

Linux PHP升级方法

安装WordPress提示:

Your server is running PHP version 5.4.16 but WordPress 5.2.1 requires at least 5.6.20.

LAMPLNMP当前运行的PHP版本为5.4,而该版本的WordPress需要PHP 5.6及以上版本,好吧,升级PHP版本吧。

PHP版本升级教程

1、查看当前PHP版本
命令:php -v,可以通过该命令查看下当前的PHP版本

2、升级软件仓库
执行下方两条命令来升级Linux软件仓库

3、删除PHP
命令:yum remove php-common
执行上方命令来删除当前版本的PHP

4、安装php 5.6版本
以安装php 5.6版本为例,执行下方命令来安装新版本PHP

5、重启httpd
CentOS 6和CentOS 7重启httpd服务的命令是不同的
CentOS 6+执行命令:service httpd restart
CentOS 7+执行命令:systemctl restart httpd.service

6、查看升级后的PHP版本
命令:php -v
再次执行php -v命令来查看当前的PHP版本,证明PHP升级成功。

2020双十二服务器价格出炉,又降价了!
双十二拼团:阿里云双十二服务器拼团(全网最低价)
①真便宜:阿里云服务器69元1年,203元3年(全网最低价)
②腾讯云:腾讯云双十二服务器特惠88元一年起(有高配)
③代金券:2020阿里云双十二代金券一键领取中